IBM Support

changeOrder API adds hold type with status 1100 on order with non-existing hold

Troubleshooting


Problem

Attempts to run changeOrder adds a hold type 1100 on order with a non-existing hold in IBM Sterling Order Management

Symptom

Steps to reproduce:
Order doesn't have HoldType=TEST_HOLD. While calling to changeOrder API to resolve the hold (with the below input XML) is adding the hold on the Order. The hold was not present on the Order at all.

Input XML to changeOrder API:
-----------------------------------------
<Order DocumentType="0001" EnterpriseCode="MG" OrderNo="961751832802"
Action="MODIFY" ModificationReasonText="Allow">
<OrderHoldTypes>
<OrderHoldType HoldType="TEST_HOLD" ReasonText="TEST_HOLD"
Status="1300"/>
</OrderHoldTypes>
</Order>
-----------------------------------------

Cause

This is working as designed.

Environment

When changeOrder encounters a different holdtype than ones already present in the order, it goes and create a new holdtype. As per design a holdType is always created in created status.

Resolving The Problem

To resolve the appropriate hold, you can call getOrderDetails (with appropriate template) to get the OrderHoldTypes of order. Then, you should create the input xml for changeOrder with these OrderHoldTypes after substituting the status to 1300.

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Installation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
11 February 2020

UID

swg21991521