IBM Support

cc.fExpVal fails when the Controller application server's Regional Settings are configured to some incompatible values

Troubleshooting


Problem

User creates an Excel spreadsheet which contains some cc.fExpVal formulae. User clicks 'Controller - Reports - Export Data'. The user confirms the action, and then the expected 'success' message appears. However, the updated data values do not appear in the Controller system.

Symptom

Confirmation question correctly appears:

    Do you really want to export values to IBM Cognos Controller?

Afterwards, a success message appears:
    All 1 values were successfully exported and the data has been saved.

However, the data does *not* actually appear in the system.

Cause

There are several possible causes for similar symptoms.

  • For more examples, see separate IBM Technote #1445442.

This Technote specifically relates to the scenario where the cause is a defect (reference APAR PI29570) in Controller, triggered by an incompatible regional settings configuration on the Controller application server.

Environment

This problem has been seen with some Regional Settings, for example South Africa:

Resolving The Problem

Fix:

Upgrade to a future version of Controller (when available) which contains a fix for this defect.

  • TIP: To be automatically notified when this version is available, please subscribe to APAR PI29570.

Workaround:

Modify the Regional Settings (on the Controller application server) to be compatible with Controller.

  • For example, use: English (United Kingdom).

Steps:

TIP: The following steps are based on Windows 2012, with Controller 10.2.

  • If your system is different, the instructions will need to be modified accordingly.

1. Ensure that there are no other users on the system (downtime)

2. Logon to the Controller application server as a Windows administrator

3. Open "Control Panel - Region"

4. Inside 'Formats' tab, modify the 'main' regional settings to 'English (UK)':


5. Click "Administrative"

6. Click 'Change system locale' to also change to English (United Kingdom):


7. Reboot application server

8. Logon to the Controller application server as a Windows administrator

9. Open "Control Panel - Region"


10. Open the tab 'Administrative'
11. Click the button 'Copy Settings'
12. Tick both boxes ("Welcome screen and system accounts" & "New user accounts"):
cid:_1_102D6558102D62EC0036B54D80257D72
13. Click OK
14. Reboot
15. Re-test.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21687144