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Case Init job fails to complete due to The requested item was not found Non-repository object not found errors

Troubleshooting


Problem

Case Init job fails to complete due to The requested item was not found Non-repository object [connection point name] not found errors

Symptom

The Case Init job pod log has the following error:
Sep 14, 2022 7:16:25 PM com.ibm.ecm.icm.config.init.services.DefineTargetEnvironment defineTargetEnv
SEVERE: The requested item was not found. Non-repository object cpe_conn_tos not found.
java.lang.Exception: Defining Target Environment is Failed
    at com.ibm.ecm.icm.config.init.ConfigureTargetEnvironment.configureTargetEnv(ConfigureTargetEnvironment.java:109)
    at com.ibm.ecm.icm.config.init.InitCaseManager.main(InitCaseManager.java:30)  ...
 
The Content Platform Engine pod logs have this error:
2022/09/14 19:16:22.416+0000 RPCHandler 61e42577 [Error] ; Exception: com.filenet.api.exception.EngineRuntimeException: FNRCE0040E: E_NOT_AUTHENTICATED: The user is not authenticated. Message was: CWWKS1100A: Authentication did not succeed for user ID p8admin_dev. An invalid user ID or password was specified. 
        at com.filenet.apiimpl.core.UserPasswordToken.getSubject(UserPasswordToken.java:131) 
        at com.filenet.apiimpl.core.UserPasswordToken.getSubject(UserPasswordToken.java:73) 
        at com.filenet.engine.context.CallState.getSubject(CallState.java:467) 
        at com.filenet.engine.context.CallState.getSystemSubject(CallState.java:437) 
        at com.filenet.engine.unified.UnifiedApiImpl.getPeServiceSubject(UnifiedApiImpl.java:132) 
        at com.filenet.engine.unified.UnifiedApiImpl.beginImp(UnifiedApiImpl.java:89) 
        at com.filenet.engine.util.EngineToApiInjecter.beginImp(EngineToApiInjecter.java:302) 
        at com.filenet.apiimpl.util.ApiToEngineBridge.beginImp(ApiToEngineBridge.java:367) 
        at com.filenet.apiimpl.util.UnifiedUtil.beginImp(UnifiedUtil.java:68) 
        at filenet.jpe.security.cemp.CEConnectUtil.pushSystemCEConForThreadWithPCH(CEConnectUtil.java:201) 
        at filenet.jpe.security.cemp.CEConnectUtil.pushSystemCEConForThread(CEConnectUtil.java:185) 
        at filenet.jpe.security.cemp.CPSiteInfo.init(CPSiteInfo.java:157) 
        at filenet.jpe.security.cemp.CPSiteInfo.getSiteInfoForCP(CPSiteInfo.java:96) 
        at filenet.jpe.rpc.appserver.PEEngineServlet.doPost(PEEngineServlet.java:617) 
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:706) 
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:791) 
        at com.ibm.ws.webcontainer.servlet.ServletWrapper.service(ServletWrapper.java:1258) 
... 
    Caused by: com.ibm.ws.security.authentication.AuthenticationException: CWWKS1100A: Authentication did not succeed for user ID p8admin_dev. An invalid user ID or password was specified. 
        at com.ibm.ws.security.authentication.jaas.modules.UsernameAndPasswordLoginModule.login(UsernameAndPasswordLoginModule.java:92) 
        at com.ibm.ws.kernel.boot.security.LoginModuleProxy.login(LoginModuleProxy.java:51) 

Cause

Content Platform Engine passwords are changes and the ibm-fncm-secret secret is updated.
However, the Content Platform Engine system user password in ACCE is not updated.

Environment

Cloud Pak for Business Automation 21.0.3 with FileNet Content Manager and Workflow capabilities enabled.

Resolving The Problem

  1. Update the System User password in ACCE. For example:
    • image-20221108110323-1
  2. Scale down the CPE pods to zero, and scale them back up.
  3. Rerun the Case Init job:
    oc get job|grep case-init-job
    oc get jobs <case-init-job-name> -o json | jq 'del(.spec.selector)' | jq 'del(.spec.template.metadata.labels)' | oc replace --force -f -

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSBYVB","label":"IBM Cloud Pak for Business Automation"},"ARM Category":[{"code":"a8m3p000000hAh9AAE","label":"Operate-\u003EBAW Install\\Upgrade\\Setup-\u003EBAW Case Manager"}],"ARM Case Number":"TS010494140","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"21.0.3"}]

Document Information

Modified date:
08 November 2022

UID

ibm16837925