Troubleshooting
Problem
Cloud Pak for Data 2.5 add-ons install failed with 'Cannot write: No space left on device"
Symptom
Cause
This error occurs when the installer pod's PV storage is full. Usually when the underlying the storage is the PORTWORX where the PV sizes are not auto scaled.
Environment
- Cloud Pak for Data 2.5
- Portworx 2.3x
- OpenShift 3.11x
Resolving The Problem
Steps:
1. Log into Installer pod
2. Look for the images folders under it /mnt/installer/
3. cd /mnt/installer; find . -name "images" -print
3. Remove the folders
Or
Airgap install steps. Make sure to move "images" folder outside the --load-from after "preloadImages" steps.
- $ ./cpd-linux adm -a wml -n zen --version 2.1.0.0 --load-from=./wml --apply
- $ ./cpd-linux preloadImages --action push --assembly wml -v 2.1.0.0 --load-from=./wml --transfer-image-to docker-registry.default.svc:5000/zen --target-registry-username apadmin --target-registry-password $(oc whoami -t) --insecure-skip-tls-verify
- $ mv ./wml/assembly/wml/x86_64/2.1.0.0/images wml-images
- $ ./cpd-linux --assembly wml --namespace zen --storageclass portworx-shared-gp3 –load-from=./wml --cluster-pull-prefix docker-registry.default.svc:5000/zen --insecure-skip-tls-verify --override ./wml-override.yaml --version 2.1.0.0 --accept-all-licenses
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSHGYS","label":"IBM Cloud Pak for Data"},"ARM Category":[{"code":"a8m3p000000UoTPAA0","label":"Storage"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"2.5.0"}]
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Document Information
Modified date:
24 August 2023
UID
ibm16217362