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Cannot switch to 'Intercompany Details' window when running Controller inside Citrix published application

Troubleshooting


Problem

User opens a Data Entry form. User clicks on the InterCompany (IC) button. This (correctly) launches a new 'pop up' window, which contains the 'Intercompany Details' functionality. Unfortunately the end user cannot select this.

Symptom

User clicks on the Intercompany button:

On the taskbar, the user can see that there is a separate Citrix published application ("Intercompany Details - \\Remote") visible:


However, the end user cannot select/choose this 'new' window.

Cause

The saved position settings (stored inside the end user's 'ccr.config' configuration file) are invalid for the monitor/size that the user is using to display Controller.

More Information:
Imagine a scenario where the end user has two PCs. One has a large monitor, and one has a small monitor. The user uses Controller via Citrix on both systems.

Controller stores the position of the window screens inside 'ccr.config' (see separate Technote #1347666 for more details). If the user moves the Intercompany Details screen to a far corner of the screen, then (when later using the smaller monitor) the saved position may be on an invalid position on the screen. Therefore it appears minimised.

Resolving The Problem

Long-term Fix:
Modify the 'bad' end user's settings, so that it stops Controller from remembering screen positions

  • In other words, for this 'bad' user only (per user setting) Controller will no longer remember/save the location/size of Windows positions.

Steps:
Each individual user should do the following:
1. Click "Maintain / User / Personal Defaults > tab Layout (2)"
2. Untick the box 'Save Window Size':

3. Click Save
4. Logoff from Controller, and re-launch the Controller client.

===================================================
NOTE: The above 'Save Windows Size' change is stored inside the database, inside the 'xconfig' table. It is recorded separately for each individual user:

Therefore:
  • Each end user must make this change separately
  • They must repeat the change for each separate database that they use (for example 'production', 'test' and so on).
===================================================

Workaround #1
Modify the settings (inside the end user's CCR.CONFIG file) to look similar to:
    <add key="frmDErepvalICMpopup-Left" value="2160" />
    <add key="frmDErepvalICMpopup-Top" value="2340" />
    <add key="frmDErepvalICMpopup-Width" value="9345" />
    <add key="frmDErepvalICMpopup-Height" value="6675" />

See separate Technote #1347666 for full details.

Workaround #2 (only works in some environments)
Right-click on the 'Intercompany Details' icon (on the taskbar) and choose 'Maximise'.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21672412