IBM Support

Cannot see NTLM in list of providers for IIS Windows Authentication

Troubleshooting


Problem

Customer has problems in their Controller application caused by a missing NTLM provider. * See separate Technote #1662734 for details. To solve this, the customer needs to add NTLM to the list of providers. However, NTLM does not appear inside the 'available' list.

Symptom

User cannot see NTLM inside current list of "Enabled Providers":


Therefore, user clicks 'Available Providers' drop-down list.

They expect to be able to choose 'NTLM' there, but it is missing from the list:

Cause

Third party (Microsoft) issue in their IIS web server technology.

Environment

Controller application server based on Windows 2008 R2.

Resolving The Problem

Re-initialise the kernel-mode authentication subsystem in IIS.

Steps:


1. Logon to the Controller application server as a Windows administrator
2. Launch IIS Manager
3. Locate the part of the website (typically the 'Default Web Site') where the Windows authentication has been enabled from.
4. Open Authentication.
5. Click 'Windows Authentication - Advanced Settings'.
6. Untick 'Enable Kernel-mode authentication' and click OK.
7. Click Providers.
8. Remove NTLM and Negotiate.
9. Click OK and restart IIS.
  • TIP: Launch a command prompt and type: IISRESET

10. Click AdvancedSettings.
11. Tick "Enable Kernel-mode authentication" and click OK.
12. Click Providers.
13. Add NTLM and Negotiate.
14. Click OK and restart IIS.
  • TIP: Launch a command prompt and type: IISRESET

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21662831