IBM Support

Cannot save more than one PDF file from Standard Reports ('System Reports')

Troubleshooting


Problem

User runs a standard report (also known as a 'system report'). By default, this appears as an HTML report. User then changes the 'select format' to 'PDF', and clicks on the 'save' icon. This works OK (by default the filename is 'cognos.pdf'). Afterwards, user runs a different standard report, and then tries to perform the same actions (to save as PDF). When they click the 'save' icon, nothing happens.

Symptom

The first time the user clicks 'save' the 'file explorer' dialogue box appears (prompting for where to save the cognos.PDF file):


However, if the end user re-runs a report (and tries again to save to PDF) the 'Save' button does not seem to work. The 'Save As' dialogue box never appears.

Cause

Limitation of third party product (Adobe Acrobat Reader) in some environments.

More Information:
The Adobe Reader client installs both the 'main' PDF reader tool (the full client application) and also a smaller 'web client'.
  • This Adobe Reader web client is installed as a plugin in Microsoft Internet Explorer
  • By default, this 'web client' is what gets activated inside the Cognos report display box.
Unfortunately, in some environments this 'web client' suffers from an inability to save more than one PDF file.

Resolving The Problem

Fix:

There are several different methods which have been seen to solve the problem in different environments.

  • Choose the method that works for your environment.
 

Method #1

Disable the Adobe Reader 'web client' and instead use the 'main' Adobe Reader client.

  • TIP: After doing this, users may prefer to block the default 'PDF' auto-creation. To achieve this, they can use the local preference: StandardReportBackProc
For more details, see separate IBM Technote #1364719.

Steps:

The steps will vary depending on the version of Adobe installed.

  • Below are some examples
  • For more information, see separate IBM Technote #6209640.
  
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Example #1 -  Adobe Reader XI

1. From the Start Menu, launch 'Adobe Reader'

2. Click 'Edit - Accessibility - Setup Assistant'
3. Click Next, Next, Next, Next
4. Untick 'Display PDF documents in the web browser':
5. Click 'Done'
6. Exit Adobe Acrobat Reader
7. Launch Controller & test

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Example #2 - Adobe Acrobat Pro DC

This is currently not officially supported for Controller. The following instructions are therefore purely offered as a courtesy (best endeavour - unsupported):

1. From the Start Menu, launch 'Adobe Acrobat DC'


2. Click 'Edit - Manage Tools'
3. Scroll down, and click 'Accessibility':


4. On the right-hand side, click "Setup Assistant":


5. Click Next, Next, Next, Next
4. Untick 'Display PDF documents in the web browser':

5. Click 'Done'
6. Exit Adobe Acrobat Writer (Adobe Pro)
7. Launch Controller & test
 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 

Method #2

Upgrade the version of Adobe Acrobat Reader.

  • In one real-life customer case, the problem was solved after upgrading the Adobe Reader (on the user's PC) from Adobe Acrobat Reader X to XI (from v10 to v11).
 

Workaround:

Close Controller. Re-launch Controller. Re-run standard report.

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Document Information

Modified date:
15 May 2020

UID

swg21680316