IBM Support

Cannot run the macro 'cc.CompareDb'. The macro may not..." when try to open Data Entry form, caused by multiple Controller clients being installed

Troubleshooting


Problem

User launches the 'main' Controller client. User clicks 'Company - Data Entry - Reported Values'. An error appears.

Symptom


Microsoft Excel
... Cannot run the macro 'cc.CompareDb'. The macro may not be available in this workbook or all macros may be disabled.

Cause

There are several possible causes for this error.

  • TIP: For more examples, see separate IBM Technote #1971878.

This Technote specifically relates to the scenario where the cause is that the client device has (mistakenly) got multiple different versions of the Controller client installed.

Environment

Example:

In one real-life customer example, the client device had 3 different versions of Controller client installed simultaneously:


Resolving The Problem

Ensure that only one version of the Controller client is installed.

Steps:
In one real-life example, the solution was to:
1. Logon to the client device as a Windows administrator
2. Inside Control Panel (Add/Remove Programs):

  • First uninstall the 10.3.1 Controller client
  • Then uninstall 10.2.1 client
  • Then uninstall 10.1 client
[In other words, uninstall ALL the Controller clients first, to make it clean.]

3. Install the relevant Controller client (for example the 10.3.1 local client "CCRLocalClient64.MSI")

4. Test.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.3.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22016881