IBM Support

"Cannot run the macro 'cc.CompareDb'. The macro may not..." when launch Excel via the Controller Excel link button (plus "Cannot run the macro 'cc.LockScreen'" error when using 'Reports - Run') triggered by version of Excel (in some environments only)

Troubleshooting


Problem

User launches Controller classic client (CCR.EXE). User clicks 'X' button ("Controller Link").
  • An error appears.
User then tries clicking 'Reports - Run'. User chooses report parameters, and then clicks 'run' button.
  • A slightly different error appears.

Symptom

(1) When click green 'X' button:
image 2187
image 2181
Error Launching menu item "Controller Link"
Cannot run the macro 'cc.CompareDb'. The macro may not be available in this workbook, or all macros may be disabled.
(2) When click green 'X' button:
image 2182
Standard Error
Number: 1004
<…>
Cannot run the macro 'cc.LockScreen'. The macro may not be available in this workbook, or all macros may be disabled.

Cause

There are several known causes for similar errors.
  • TIP: See separate IBM Technote #273107 for more information.
This Technote specifically relates to the scenario where the cause is a limitation triggered by the specific (rare) client device environment.

Environment

The problem is rare. It only affects a small number of environments.
Example (bad):
In the following environment, the error/problem occurred:
- Office 365 ProPlus (16.0.10730.20348) 32-bit
- Version 1808 (Build 10730.20348 Click-to-Run) Semi-annual Channel
image 2191
image 2192
image 2190
Example (good):
In the following environment, everything worked OK (no error):
- Office 365 ProPlus (16.0.12325.20280) 32-bit
- Version 1912 (Build 12325.20298 Click-to-Run) Monthly Channel
image 2184
image 2185
image 2183

Diagnosing The Problem

Inside Excel, open the 'Add-ins' section. The names of the 'Active Application Add-ins' will look wrong on a 'bad' client device:
image 2188
  
Compare the above with a 'good' client device (below):
image 2186

Resolving The Problem

In one real-life example, the solution was to:
(a) Uninstall Excel 365 32-bit
(b) Install Excel 365 64-bit

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.4.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
22 January 2020

UID

ibm11282036