IBM Support

Cannot open a Case solution project in Case Manager Builder, getting "A system error occurred: {0} A system-level error such as an I/O exception or a parsing error occurred. " error

Troubleshooting


Problem

No users are able to open a Case solution project in Case Manager Builder. It generates "A system error occurred: {0} A system-level error such as an I/O exception or a parsing error occurred. " error.

Symptom

Here is the screen capture of the error:
image-20230714140240-1

Here is the excerpt of the error reported in application server log:
...

2023-07-12T11:25:34.214+0000] 00000ec8 id=00000000 com.ibm.casemgmt.api.DeployedSolution > getPEConnectionPoint() ENTRY

[2023-07-12T11:25:34.214+0000] 00000ec8 id=00000000 com.ibm.casemgmt.api.DeployedSolution > loadSolutionCallCache() ENTRY

[2023-07-12T11:25:34.214+0000] 00000ec8 id=00000000 com.ibm.casemgmt.api.DeployedSolution < loadSolutionCallCache() RETURN null

[2023-07-12T11:25:34.215+0000] 00000ec8 id=00000000 om.ibm.casemgmt.intgimpl.callcache.DeployedSolutionCallCache > getUnmodifiableSolutionConfiguration() ENTRY

[2023-07-12T11:25:34.215+0000] 00000ec8 id=00000000 om.ibm.casemgmt.intgimpl.callcache.DeployedSolutionCallCache < getUnmodifiableSolutionConfiguration() RETURN com.ibm.casemgmt.intgimpl.targetos.SolutionConfiguration$UnmodifiableImpl@e56231f2

[2023-07-12T11:25:34.215+0000] 00000ec8 id=00000000 com.ibm.casemgmt.intgimpl.targetos.SolutionConfiguration > getConnectionPoint() ENTRY

[2023-07-12T11:25:34.215+0000] 00000ec8 id=00000000 com.ibm.casemgmt.intgimpl.targetos.SolutionConfiguration < getConnectionPoint() RETURN

[2023-07-12T11:25:34.215+0000] 00000ec8 id=00000000 com.ibm.casemgmt.api.DeployedSolution

 

[2023-07-12T11:25:34.218+0000] 00000ec8 id=00000000 com.ibm.casemgmt.intgimpl.apibridge.ApiBridge < getCaseMgmtExceptionClassBridge() RETURN com.ibm.casemgmt.api.exception.CaseMgmtException$ClassBridgeImpl@b7b09be1

[2023-07-12T11:25:34.218+0000] 00000ec8 id=00000000 com.ibm.casemgmt.api.exception.CaseMgmtException > access$1800() ENTRY A0024E.PE_LOGIN_FAILED Failed to retrieve bootstrap information.

java.net.MalformedURLException: "" is not a valid Connection Point URI.

at filenet.vw.api.VWSession.formulateURLForBootstrap(VWSession.java:5591)

at filenet.vw.api.VWSession.logon(VWSession.java:842)

at com.ibm.casemgmt.api.context.BaseVWSessionCache.getVWSession(BaseVWSessionCache.java:70)

at com.ibm.casemgmt.rest.handlers.GetLaunchableEntitiesForCurrentUser.getListOfAccessibleSolutionsForUser(GetLaunchableEntitiesForCurrentUser.java:407)

at com.ibm.casemgmt.rest.handlers.GetLaunchableEntitiesForCurrentUser.getListOfAccessibleSolutions(GetLaunchableEntitiesForCurrentUser.java:387)

at com.ibm.casemgmt.rest.handlers.GetLaunchableEntitiesForCurrentUser.onGet(GetLaunchableEntitiesForCurrentUser.java:175)

at com.ibm.casemgmt.rest.ACMRESTServlet.doMethod(ACMRESTServlet.java:417)

at com.ibm.casemgmt.rest.ACMRESTServlet.doGet(ACMRESTServlet.java:271)

...

Cause

PE Connection Point property of the deployed solution has an empty value. The property is expecting a connection point value.

Resolving The Problem

1. Log in to Administrative Console for Content Platform Engine (ACCE).
2. Navigate to target object store > Browse > Root Folder > IBM Case Manager > Solution Deployments > double-click a solution name > click Properties tab > look for "PE Connection Point" name. Make sure it has a valid connection point value.  See the screen capture here:
image-20230714141610-2

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSBYVB","label":"IBM Cloud Pak for Business Automation"},"ARM Category":[{"code":"a8m3p000000LPqyAAG","label":"Design-\u003EBAW App Development-\u003ECase Manager"}],"ARM Case Number":"TS013584925","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
14 July 2023

UID

ibm17012299