IBM Support

Cannot load the Advanced page of an automation Case solution project

Troubleshooting


Problem

A user clicked the Advanced option of the Case solution project, and it returns a blank page.

Symptom

A user clicked on the Advanced option of the Case solution project, and it returns a blank page. See screen captures here:
image-20230713142931-1
image-20230713143213-2

Cause

The authentication points to the target object store. It should be pointing to the design object store instead.  See the screen capture here:
image-20230713144039-3

Diagnosing The Problem

The browser console shows error as follows:
Uncaught TypeError: Cannot read properties of undefined (reading 'objectStore')
    at Object.eval (eval at <anonymous> (ecm.js.uncompressed.js:265359:11), <anonymous>:5581:51)
    at Object.requestCompleteCallback (dojo.js.uncompressed.js:42049:48)
    at Object._onFinished (ecm.js.uncompressed.js:105827:8)
    at Object.<anonymous> (ecm.js.uncompressed.js:105457:7)
    at XMLHttpRequest.<anonymous> (dojo.js.uncompressed.js:42049:48)
IBM Content Navigator debug file shows log entries as follows:
...

com.ibm.casemgmt.api.exception.CaseMgmtException: FNRPA0282E The path for the solution folder was not found: /IBM Case Manager/Solutions/<solution name>

at com.ibm.casemgmt.api.exception.CaseMgmtException.createException(CaseMgmtException.java:100)

at com.ibm.casemgmt.api.exception.CaseMgmtException.access$1600(CaseMgmtException.java:62)

at com.ibm.casemgmt.api.exception.CaseMgmtException$ClassBridgeImpl.createException(CaseMgmtException.java:447)

at com.ibm.casemgmt.intgimpl.designos.ConnectionDefinitionDocument.fetchDefinitionForSolution(ConnectionDefinitionDocument.java:164)

...

com.ibm.ecm.icm.accm.util.AccmException: FNRPA0078E The connection definition was not found.

at com.ibm.ecm.icm.accm.repository.GetProjectAreas.getSolutionProjectArea(GetProjectAreas.java:103)

at com.ibm.ecm.icm.accm.services.ProjectAreaService.getProjectAreaFromSolutionNObjStore(ProjectAreaService.java:165)

at com.ibm.ecm.icm.accm.services.ProjectAreaService.doExecute(ProjectAreaService.java:107)

at com.ibm.ecm.icm.accm.services.BaseService.execute(BaseService.java:140)

at com.ibm.ecm.util.PluginUtil.invokeService(PluginUtil.java:1797)

...

Caused by: com.ibm.casemgmt.api.exception.CaseMgmtException: FNRPA0078E The connection definition was not found.

at com.ibm.casemgmt.api.exception.CaseMgmtException.createException(CaseMgmtException.java:100)

at com.ibm.casemgmt.api.exception.CaseMgmtException.access$1600(CaseMgmtException.java:62)

at com.ibm.casemgmt.api.exception.CaseMgmtException$ClassBridgeImpl.createException(CaseMgmtException.java:447)

...

...

Resolving The Problem

1/ Login to IBM Content Navigator admin desktop.
2/ Verify the bawadin desktop authentication connection is configured with the design object store. See the screen capture here:
image-20230713144322-4

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSBYVB","label":"IBM Cloud Pak for Business Automation"},"ARM Category":[{"code":"a8m3p000000LPr8AAG","label":"Use-\u003EBAW App Usage-\u003ECase Manager"}],"ARM Case Number":"TS013558400","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
13 July 2023

UID

ibm17011931