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Cannot download pmlib from IBM Maximo Predict notebooks

Troubleshooting


Problem

pmlib cannot be downloaded from the IBM Maximo Predict notebooks.

Symptom

When you try to download pmlib from the notebooks, you get the following error message:
'detected need to restart the mahi super apikey process' in predict-api log
The following text is a typical log message
[2021-07-01T18:57:01.192+0000] 0000021e com.ibm.apm.util.MahiUtil                                    
I getAssetsPerGroup:true:INPUTSTREAM:400:{"Error":{"extendedError":{"moreInfo":{"href":"http:\/\/localhost\/maximo\/api\/error\/messages\/BMXAA9549E"}},"reasonCode":"BMXAA9549E","message":"BMXAA9549E - The API key token is invalid. Either the token may have expired or the token has been revoked by the administrator.","statusCode":"400"}}
[2021-07-01T18:57:01.192+0000] 0000021e com.ibm.apm.util.MahiUtil                                    
I INPUTSTREAM:400:{"Error":{"extendedError":{"moreInfo":{"href":"http:\/\/localhost\/maximo\/api\/error\/messages\/BMXAA9549E"}},"reasonCode":"BMXAA9549E","message":"BMXAA9549E - The API key token is invalid. Either the token may have expired or the token has been revoked by the administrator.","statusCode":"400"}}
[2021-07-01T18:57:01.192+0000] 0000021e com.ibm.apm.util.MahiUtil                                    
I detected need to restart the mahi super apikey process

Cause

The API key was deleted from the Maximo Health APIKEYTOKEN table (prop:mxe.PMIUser). 

Resolving The Problem

Restart the Maximo Predict and Maximo Health integration by, in Maximo Predict, updating the MAS_INTG_STATUS field in the PMITENANT table to ‘PENDING’.

  1. Log in to the Maximo Predict database from an SQL client.
  2. Open the Maximo Predict schema, such as MAS_IVT07REL85_PREDICT. Notice the Maximo Predict schema name is defined at deployment and activation by administrator. Contact your administrator for the schema name. 
  3. Locate the PMITENANT table and the PMI_TENANT_ID for the particular tenant that you are interested in. Typically, only 1 tenant exists. 
  4. Run the following SQL query to update the integration status to PENDING. Replace the schema name and PMI_TENANT_ID variables with your schema name and ID. UPDATE "schema name"."PMITENANT" SET MAS_INTG_STATUS = 'PENDING' WHERE PMI_TENANT_ID =ID;
  5. Wait for 10 minutes for the APMJob integration job to run
  6. Verify that the issues are resolved by running the notebook that uses the API key.

Document Location

Worldwide

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Document Information

Modified date:
27 July 2021

UID

ibm16471607