IBM Support

Cannot connect to Connect:Enterprise node

Troubleshooting


Problem

Cannot connect to Connect:Enterprise node

Symptom

Cannot connect to Connect:Enterprise node

Control Center error:

CCTR035E
Error: Failed to connect to server. Check for invalid userid/password, improper authority for userid, unsupported level of server or no license slot available to monitor the server.

Enterprise Admin GUI error:

504 failed to connect.

The Connect:Enterprise SVD trace shows this error:

rapi_open_role: failed acqopenifile - rc = 12

Cause

Connect:Enterprise installation was not completed properly, roles and admin databases were not created. Connect Control Center and Enterprise Administration Tool requires that the userID that accesses the Connect:Enterprise server has an Administrator role

Resolving The Problem

Issue the following commands from the $CMUHOME/database directory:

../<OS>/bin/create.roles.db create

../<OS>/bin/create.admin.role create <ceuser>

[{"Product":{"code":"SS9GLA","label":"IBM Control Center"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSFVK3","label":"IBM Sterling Connect:Enterprise for UNIX"},"Business Unit":{"code":"BU055","label":"Cognitive Applications"},"Component":"Not Applicable","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Historical Number

PRI6775

Product Synonym

[<p><b>]Fact[</b><p>];[<p>]Connect Control Center Windows (Engine);All Releases[</p>] ;[<p>]Connect:Enterprise UNIX Administration Tool;All Releases[</p>]

Document Information

Modified date:
17 December 2019

UID

swg21532915