IBM Support

Cancelling Extraction Training Fails with Automation Document Processing

Troubleshooting


Problem

When an Automation Document Processing Developer cancels extraction training, the cancellation never completes and the training cannot be rerun.

Cause

If the extraction training process fails internally, there is not a running process to receive the cancellation request.  So the cancellation never completes.

Resolving The Problem

Reset the training status in the project database.
  1. To get a list of project databases, on the Db2 server navigate to the \cert-kubernetes\ACA\configuration-ha\DB2 folder and run ProjectList.sh or ProjectList.bat, depending on the database server type.
  2. Note the database name associated with the current project.
  3. Connect to the project database and reset the status.
    • UPDATE <YourProjectDB>.TRAINING_LOG SET STATUS=6 WHERE STATUS=5
Although fast training completes in a few minutes, full training can take an hour or two, and if done on a system without a GPU can potentially take a couple of days. If the extraction training continues to fail and you are running full training, retrain by using fast training to see whether that resolves the issue. 
If extraction training and cancellation continue to fail, open a ticket with Support, noting the time you last ran extraction training and providing the output of the adp_mustgather script.  For the script and more information on support, see MustGather - IBM Business Automation Document Processing.

Document Location

Worldwide

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Document Information

Modified date:
27 November 2023

UID

ibm17083079