IBM Support

Calling monitorItemAvailability API raises event on all availability changes.

Troubleshooting


Problem

Attempts to run monitorItemAvailability API raises event on all availability changes irrespective of the availability threshold in IBM Sterling Selling and Fulfillment Suite.

Symptom

While calling monitorItemAvailability API, whether RaiseEventOnAllAvailabilityChanges flag is set to Y or N, REALTIME_AVAILABILITY_CHANGE or REALTIME_AVAILABILITY_CHANGE_LIST event is raised on all availability changes regardless of whether availability exceeds or falls below specified thresholds. monitorItemAvailability API will always write into the YFS_INVENTORY_ALERTS table

Cause

This is working as designed.

Diagnosing The Problem

The API behaves in the same way that RTAM Full sync. Full sync always raises the event. So, the attribute exposed in the input is actually not of any use.

Resolving The Problem

The purpose of the monitor API is to do the same work as RTAM and provide you with availability. So, monitorItemAvailability API will always write into the YFS_INVENTORY_ALERTS table. If you are only looking for availability without writing to YFS_INVENTORY_ALERTS table, you could explore getAvailableInventory/findInventory APIs.

[{"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Component":"Distributed Order Management","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21984341