IBM Support

Caching Proxy might not start on Windows

Troubleshooting


Problem

When you install Caching Proxy on a system with Microsoft Windows, the process for Caching Proxy might not start.

Symptom

You might see the following error message:

This application has failed to start because icuuc18.dll was not found. Re-installing the application may fix the problem.

Cause

The PATH environment variable is not set correctly.

Resolving The Problem

To resolve the problem, append the path to the Caching Proxy library files to the PATH variable:

  1. Go to system properties by right clicking on My computer.
  2. Go to the Advanced tab and click on Environment variables.
  3. Select the Path variable from the list of system variables and click Edit.
  4. Append the following path at the end of the current entry:

    CP_PRODUCT_ROOT\icu\lib;CP_PRODUCT_ROOT\admin\platform\bin;CP_PRODUCT_ROOT\cp\Bin;CP_PRODUCT_ROOT\cp\lib\plugins\pac;GSKIT_PRODUCT_ROOT\bin;GSKIT_PRODUCT_ROOT\lib;

    For example:

    C:\PROGRA~1\IBM\edge\CACHIN~1\icu\lib;C:\PROGRA~1\IBM\edge\CACHIN~1\admin\platform\bin;C:\PROGRA~1\IBM\edge\CACHIN~1\cp\Bin;C:\PROGRA~1\IBM\edge\CACHIN~1\cp\lib\plugins\pac;C:\PROGRA~1\IBM\gsk8\bin;C:\PROGRA~1\IBM\gsk8\lib;

  5. Click Ok.
  6. Close the System Properties panel, and restart the system.

If you still get the same error message, the icuuc18.dll file might be missing. You can fix this problem by reinstalling the product.

[{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Edge Component","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.0","Edition":"Network Deployment","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21501762