IBM Support

CA証明書を変更後502エラーが表示されCognosへアクセスすることができない

Troubleshooting


Problem

SSL設定でCA証明書を変更したところ、Content Manager、アプリケーション・サーバーと問題なく起動したにも関わらず、Webサーバーを通じてCognosへアクセスしたところ、502エラーが表示されアクセスすることができません。

Cause

IIS側で設定しているホスト名が正しく設定されていないことが起因して本事象が発生することがあります。

Environment

分散環境(各1台のWebサーバー、 アプリケーション・サーバー、Content Managerサーバー)
WebサーバーはIISを使用

Diagnosing The Problem

  • 各Cognosコンポーネントのサーバー/IISで証明書はインポートしている。
  • IBM Cognos Configuration上のURIの設定は問題ない。

Resolving The Problem

  1. IISを開き、Default Website >  アプリケーションサーバーのAlias > URL書き換え > リバース・プロキシーを確認し、ホスト名を アプリケーション・サーバー の FQDN に変更します。
  2. http から https に変更します。
  3. Default Website > バインディングで、ホスト名をWebサーバーのFQDNに変更します。
  4. IISを再起動します。
画像付きの設定方法は下記リンク"Troubleshoot SSL for Gateway on IIS"をご参照ください。

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl5lAAC","label":"Security-\u003ESSL\/Cryptography"}],"ARM Case Number":"TS011477969","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.1.7"}]

Historical Number

734875

Document Information

Modified date:
14 December 2023

UID

ibm17096420