IBM Support

Browsing product in Web Call Center 9.3 fails with the error Could not find active search index

Troubleshooting


Problem

Attempts to browse product in IBM Web Call Center 9.3 (WCC) fails with the error 'Could not find active search index'.

Cause

The catalog index is not created in Web Call Center

Resolving The Problem

A catalog index must be created in order to enable product browsing in Web Call Center. A catalog organization must build an index of the items in the Sterling Selling and Fulfillment Foundation database before you can run a catalog search.

Steps to create an active search index:

  1. Log in to Order Management System (OMS) Foundation Console and launch the Application Manager.


  2. Navigate to Application Platform-Process Modeling-General-General-Transactions-Catalog Index Build-Time Triggered-Agent Criteria Definitions.


  3. Choose the enterprises for which you need to build the criteria,
    For example
    For enterprise=Matrix, the corresponding criteria would be Matrix_INDEX_BUILD. Update the necessary queue details to run this agent.


  4. Log in to Sterling Business Center (SBC) and load the Enterprise where you configured the SearchAgent.


  5. Navigate to Products-Item Catalog Indexes-Manage Item Catalog Indexes-Create Index.


  6. Choose the available catalog and hit Select. You will see the catalog ID in status - In progress. Note - Ensure that the there are published items for the catalog for which the index is being built.

  7. In the customer_orverrides.properties, set the following property to any location that is accessible for read/write - yfs.yfs.searchIndex.rootDirectory

    For example
    yfs.yfs.searchIndex.rootDirectory=D:\SearchIndex.In some cases you may need to pass it with a double slash based on your OS


  8. Rebuild the EAR if necessary and restart the application server.


  9. Start the Agent configured in step 3 and wait for the Catalog Index to be completed. In SBC the status will move to Completed.
    You will now be able to browse catalogs from Web Call Center

[{"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21675586