IBM Support

Blurred text and/or strange-looking fonts and/or incorrect display layout (inside Controller classic client) caused by using display scaling (not using 100% scaling = 96 DPI) - triggered by Controller not being High DPI aware

Troubleshooting


Problem

End user's display (monitor/screen) is high resolution (for example 1920 x 1080), however they have a relatively small monitor (for example 15.6").
  • Therefore this makes many/most font/text sizes appear physically small on the screen.
To make the words easier to read (less strain on the eye) the user has the Windows setting configured to scale the fonts larger (for example 125% of their original size).
  • This causes many of their local applications (for example Microsoft Excel) to have easier-to-read writing/text
  • However, when using Controller (either locally or remotely - for example via MS Terminal Server) this causes the text (in the Controller classic client) to be blurry.
If the user tries to workaround the problem (by configuring Controller client to be not high DPI aware) some of the text/boxes appear corrupt/wrong (or in the 'wrong' place).

Symptom

Scale set to 125% (unsupported):
The text looks blurred, for example:
image-20191009110325-1
Scale set to 100% (supported):
The text looks sharp, for example:
image-20191009110349-2
Scale set to 125% (unsupported) but "Disable display scaling on high DPI settings" is enabled:
Text is sharp (easy to read) but sometimes in the wrong position, for example:
image-20191009114307-2
Other symptoms:
For more examples of symptoms/problems related to this setting, see separate IBM Technotes: 1074248, 1883699, 1074132

Cause

User is using an unsupported display scaling setting.
  • Specifically, IBM does not currently support the end user's client PC's Windows display settings using a display scaling setting different from 100% (also known as having a DPI value of 96
  
More Information
Historically, software has been created to assume that the density of the screen dots is 96 per square inch.
  • However, modern hardware (specifically high definition monitors, with relatively small screen sizes like 15.6") have a higher density of dots.
To make the writing appear larger, by default modern versions of Windows scale these displays (for example by a factor of 125%).
  • This can cause some software to appear blurry.
Therefore, IBM only supports Controller client being run in with a DPI of 96 (also known as 100% scaling).
  • This is mentioned inside the documentation 'Display Settings' (link below).
TIP: For more information on how Microsoft Windows uses display scaling, see link to the Microsoft article below.

Environment

The client PC is set so that the fonts (and other similar objects) are scaled different from 100%
  • Typically they are set to 125%
These settings are named differently depending on what version of Windows is running on the device.
  • Below are some examples.
Example #1: Typical Windows 10 laptop
A typical modern laptop has the following specifications:
  • Display resolution = 1920 x 1080 (known as "Full HD" or FHD)
  • 'Display' - 'Scale and layout' - 'Change the size of text, apps, and other items' set to:     125% (Recommended)
image-20191009113637-1
Example #2: Windows 8.1
The comparable setting on Windows 8.1 was called "Let me choose one scaling level for all my displays":
Example #3: Windows 7
The comparable setting was: "Use Windows XP style DP scaling"
Example #4: Windows Vista
The comparable setting was: 'Set custom text size (DPI)' (also known as "Custom DPI setting").
  • The screenshot below shows the 'good' (correct/supported) setting where the scale is 100%.
Example #5: Windows XP
The comparable setting was: 'Control Panel' - 'Display' then 'Settings' - 'Advanced'. Then change the 'DPI setting'.

Resolving The Problem

Fix:
This is a known limitation of Controller.
Therefore, the fix is to modify the end user's client device to disable scaling.
  • In other words, have a scale factor of 100%.
Steps:
The steps vary depending on the operating system. The following is based on Windows 10:
1. On the client device, right-click on the 'Start' icon, and choose:   Run
2. Type in:     dpiscaling
image-20190918134012-1
3. Click OK
4. Inside the section 'Scale and layout' change the value of 'Change the size of text, apps, and other items' to:   100%
5. Click OK
6. Test.
   
Workaround:
Modify the client device to disable scaling for *only* the Controller application.
NOTE: This will make the fonts look smoother (less blurred) but (as a side-effect it will cause some box/layout issues in Controller.
  • For examples of these side-effects, see separate IBM Technotes.
Steps
In one real-life example, the solution was to enable "Disable display scaling on high DPI settings", by performing the following:
1. Logon onto the client device (for example the Microsoft Terminal Server)
2. Locate the file CCR.EXE
  • TIP: By default, this is here: C:\Program Files\ibm\IBM Cognos Controller Local Client
3. Right-click on 'CCR.EXE' and click 'Properties'
4. Click 'Compatability'
5. Tick "Disable display scaling on high DPI settings"
6. Click "Change settings for all users"
7. Tick "Disable display scaling on high DPI settings"
Or
5. Click  "Disable high DPI settings"
6. Click "Override high DPI scaling behaviour. Scaling performed by System"
image-20190919092618-1
image 6294
8. Click OK
9. Click OK
10. Test.

Document Location

Worldwide

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Document Information

Modified date:
24 September 2020

UID

ibm11079895