IBM Support

A blank white page is rendered while opening Websheets within Planning Analytics Workspace.

Troubleshooting


Problem

Planning Analytics Workspace returns a blank white page while rendering an embedded web-sheet or rendering a web-sheet from Planning Analytics Workspace database tree.

Symptom

All the objects including cube views, hierarchies, processes etc. render without any issues except websheets.

Cause

The issue is likely caused due to the following reasons.
1) There are issues experienced with rendering the websheets over Planning Analytics Spreadsheet Services/TM1 Web. Planning Analytics Workspace uses Planning Analytics Spreadsheet Services/TM1 Web in the background to render websheets hence any issues with these environments will result in Workspace rendering blank white pages.
2) Incorrect or dysfunctional "TM1 Application Server Gateway URI" specified within Planning Analytics Administration tool or corresponding configuration files i.e. paw.ps1/paw.env.

Resolving The Problem

1) Ensure that the "TM1 Application Server Gateway URI" specified within Planning Analytics Administration tool or corresponding configuration files i.e. paw.ps1/paw.env is working and reachable from the Workspace server.
2) Troubleshoot issues within Planning Analytics Spreadsheet Services/TM1 Web if the websheets are not rendering in these clients within Internet Explorer browser window. You may consider restarting "IBM Planning Analytics Spreadsheet Services/IBM Cognos TM1" service as appropriate.

Document Location

Worldwide

[{"Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSCTEW","label":"IBM Planning Analytics Local"},"ARM Category":[{"code":"a8m50000000KzIzAAK","label":"Planning Analytics Workspace"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
25 January 2021

UID

ibm16407128