Troubleshooting
Problem
You are monitoring Informix database(s) with IBM InfoSphere Guardium. Source Program column shows blank value in the report. All other columns/fields corresponding to the Login Packet (DB Username, OS User, Client IP, Server IP, Database Name, Service Name) are populated as expected, but Source Program is blank/missing.
Symptom
Source Program field is blank/missing in the reports.
Cause
Using older Informix Client SDK and/or Informix Server version(s) that did not support sending Source Program.
Diagnosing The Problem
Source Program is blank/missing while other fields for the Login Packet/connection string are populated.
Resolving The Problem
Install Informix CLient SDK and Informix server versions of at least below versions, or higher:
Informix Client SDK 3.70
Informix Server 11.50.FC9W
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21698109