IBM Support

Blank Screen When Logging into an HTTPS-Enabled Cognos Analytics 11.1.7 Environment

Troubleshooting


Problem

A blank screen is shown when attempting to login to a Cognos Analytics 11.1.7 environment that is HTTPS-enabled. On the network trace, a 500 or 404 error is shown on the ../bi/v1/login request.

Cause

Cognos Analytics 11.1.7 enforces an additional security check called hostname verification that checks to ensure the Subject Alternate Name (SAN) on the certificate matches the hostname used in Cognos Configuration (and the hostname being accessed).  

Diagnosing The Problem

Ensure that the SAN on the certificates used to secure a Cognos environment matches the hostname that is used in the URLs in Cognos Configuration under Environment and Cryptography > Cognos > DNS names.
For example, if the SAN on the certificates is server.mydomain.com, then all of the URLs in Cognos Configuration must use server.mydomain.com, and the DNS names field under Cryptography > Cognos must contain server.mydomain.com and any other shortnames or fully-qualified domain names (FQDNs) separated by a space. 

Resolving The Problem

Ensure that all of the URLs in Cognos Configuration match with the SAN on the certificates used to secure the environment. 
If a DNS name is used for both the SAN on the certificates and the URLs in Cognos Configuration, then check the server's hosts file to ensure the first entry is of the form <DNS IP Address> <DNS FQDN> <shortName for the Server>.

Document Location

Worldwide

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Document Information

Modified date:
01 October 2020

UID

ibm16340271