Troubleshooting
Problem
BigFix クライアントへのスキャナーのインストールがダウンロード・エラーで失敗する
Symptom
非インターネット接続環境(AirGap 環境)にて、ILMT/BigFix サーバーを構築し、監視対象の環境に BigFix クライアントを導入しました。
その後、BigFix クライアントに対してスキャナーを導入するため、BigFix コンソールから、"スキャナーのインストールまたはアップグレード"のタスクを実行したところ失敗しました。
BigFix コンソールのアクション > "スキャナーのインストールまたはアップグレード" の概要を確認したところ、以下のダウンロード・エラーが発生しています。
-----
ダウンロード・エラー: "HTTP Error 6: Couldn't resolve host name: Couldn't resolve host 'software.bigfix.com"
-----
Cause
ILMT/BigFix サーバーが非インターネット接続環境(AirGap 環境)では、別途用意したインターネット接続端末でツール(AirgapTool, Download Cacher)を実行して必要なファイルをインターネット経由で取得し、ILMT/BigFix サーバーに配置します。
それらのファイルの一部が不足しているか、正しく配置できなかった場合、Fixlet やタスクの実行時に、ILMT/BigFix サーバーがインターネット経由で情報を取得しようとします。
その際に、インターネット経由で情報が取得できず、ダウンロード・エラーが発生します。
Environment
ILMT9.x
Resolving The Problem
インターネット接続端末で、再度 AirgapTool と Download Cacher を実行し、ファイルを ILMT/BigFix サーバーに再配置してください。
必要なファイルが配置されることで、スキャナーのインストールが成功します。
尚、一度スキャナーのインストールが成功した実績のある環境でも、時間の経過によりファイルが不正な状態になる場合があるため、上記の回避策を実施してください。
Related Information
Was this topic helpful?
Document Information
Modified date:
26 April 2021
UID
swg21998985