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BAW 稼働環境におけるストレージ逼迫の原因と対策

Question & Answer


Question

Business Automation Workflow (以降 BAW) が稼働する環境のストレージが逼迫してきました。またそれに伴いパフォーマンスも劣化してきました。どのような原因と対応が考えられますでしょうか。

Cause

BAW はデフォルトの状態から特に何も対策をしていなければデータが溜まり続けるので、定期的に環境のクリーンアップ(ハウスキーピング)を実施していただく必要性がございます。デフォルトでは自動的にクリーンアップが実施されることはないので、それぞれの BAW 稼働環境の利用用途、制約や要件に応じてクリーンアップの計画と実行が必要になります。

Answer

ストレージが逼迫してきたり、システムのパフォーマンスに劣化が見られたら、まずは適切にクリーンアップの運用が行われているかどうかご確認いただく必要性がございます。(なお、以降の説明ではデータを削除する方法をご案内します。中には論理的に削除されるデータもありますが、多くの場合は物理的にデータが削除されます。従いましてデータのバックアップや削除による業務影響の有無の確認は十分に行っていただく必要があることはご理解ください。)
ご確認に際して前提となる情報があります。BAW にはいわゆる開発環境やテスト環境として用いられる Workflow Centerと (以降 WC)、いわゆる実行環境として用いられる Workflow Server がありますが (以降 WS)、対象の環境が WC か WS かどちらなのかを把握する必要があります。これは WC と WS で実施すべきクリーンアップ・アクティビティーが異なるためです。ほとんどの BAW 管理者はその環境が WC か WS かを把握しているはずですが、もし分からなければその BAW が使用するデータベースにアクセスし、下記の SQL を実行してください。結果として true が返ってくればその環境は WC であることを意味し、false が返ってきたらその環境は WS であることを意味します。
SELECT PROPVALUE FROM LSW_SYSTEM WHERE PROPKEY = 'IsRepository'
対象の環境が WC か WS か分かったら、次に以下のページを参照します。
 
保持されるデータの管理
 
上記リンクに WC 環境で実施すべきクリーンアップ・アクティビティー (Workflow Center) と、WS 環境で実施すべきクリーンアップ・アクティビティー (Workflow Server) が、それぞれ表にまとめられています。
例えば、WC 環境でしばしば問題の原因になり得るのが「名前なしスナップショット」です。もし対象の環境が WC であれば、まずは「名前なしスナップショット」を運用として定期的に削除しているかどうかをご確認いただくことを推奨します。もし実施していないようであれば、対象のリンクから説明を参照しそれを削除することをご検討ください。もちろん「名前なしスナップショット」以外にも原因になり得る項目はあるので「表 1. Workflow Center 管理のクリーンアップ・アクティビティー」をよくご覧いただき、該当環境で適切なクリーンアップ・アクティビティーが運用として行われているかどうかをご確認ください。WS 環境でしばしば問題の原因になり得るのが「プロセス・インスタンス」です。上述した WC 環境における「名前なしスナップショット」と同様に、WS 環境では「プロセス・インスタンス」が運用として定期的に削除されているかどうかをご確認いただくことを推奨します。もちろん「プロセス・インスタンス」以外にも原因になり得る項目はあるので「表 2. Workflow Server 管理者のクリーンアップ・アクティビティー」をよくご覧いただき、該当環境で適切なクリーンアップ・アクティビティーが運用として行われているかどうかをご確認ください。
WC/WS 環境とは別に BAW には Performance Data Warehouse (以降 PDW) と呼ばれるコンポーネントがあります。BAW ではパフォーマンスを管理するために、タスクやインスタンスを管理する BPM データベースから PDW と呼ばれるデータベースにデータを転送します。この文脈における「パフォーマンス」とはいわゆるコンピューター・システムの速い/遅い(性能)を意味するパフォーマンスではなく、ワークフローを処理するチームや個人のワークロードの側面を指します。このパフォーマンスの統計データが PDW DB に蓄積するので「表 3. データベース管理者用のクリーンアップ・アクティビティー」をよくご覧いただき、該当環境で適切なクリーンアップ・アクティビティーが運用として行われているかどうかをご確認ください。
 
稀にログ・ファイル等がストレージを逼迫する場合があります。その場合は「表 4。 一時ディレクトリー用のクリーンアップ・アクティビティー」をよくご覧いただき、該当環境で適切なクリーンアップ・アクティビティーが運用として行われているかどうかをご確認ください。

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Document Information

Modified date:
25 July 2024

UID

ibm17160959