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AwardAmount gets zeroed out after cancelling an order in IBM Sterling Order Management

Troubleshooting


Problem

The output of getOrderDetails API shows AwardAmount as 0 once the order is cancelled in IBM Sterling Order Management

Symptom

In getOrderDetails API output, AwardAmount is returned as 0 for a cancelled order -

<Promotions>
<Promotion IsExternal="Y" PromotionApplied="Y" PromotionGroup="COUPON"PromotionId="MFR-80-4" PromotionKey="2016011414515325426" PromotionType="Manufacturer Coupon">
<Awards>
<Award AwardAmount="0.00" PromotionKey="2016011414515325426"/>
</Awards>
</Promotion>
</Promotions>

Cause

Under Enterprise Pricing Rules, "Allow negative order line total after applying promotions" is set to False. The behavior observed is expected with this configuration. There can be a use case where a customer with a line cancelled calls or comes into the store and CSR needs to check the value of that coupon to match it. However, that need is in direct contradiction with "Allow negative order line total after applying promotions" disallowed.

Environment

IBM Sterling Order Management v9.3

Diagnosing The Problem

1. Create an order with Award applied. Sample input below -

<Order DisplayLocalizedFieldInLocale="en_US" IgnoreOrdering="Y" OrganizationCode="trynode" Override="Y" RequiresManagerOverride="Y" SellerOrganizationCode="trynode"
ValidateExternalCoupons="N">
<Promotions>
<Promotion ExclusivityId="MFR-2015110615554318579-1" ExclusivityType="RULE_TYPE_ITEM" IsExternal="Y" PromotionCategory="ITEM" PromotionId="MFR-2015110615554318579-3" PromotionType="Manufacturer Coupon"/>
</Promotions>
<OrderLines>
<OrderLine OrderLineKey="" OrderedQty="1">
<Item ItemID="try" UnitOfMeasure="EACH" />
<Awards>
<Award Action="Create" AwardAmount="-0.25" ChargeCategory="Discount" PromotionId="MFR-2015110615554318579-3">
</Award>
</Awards>
</OrderLine>
</OrderLines>
<PersonInfoBillTo Country="US" />
</Order>

2. Cancel the Order

3. Call getOrderDetails API for this order and observe the AwardAmount at Order\OrderLines\OrderLine\Awards\Award element.

Resolving The Problem

1. Set "Allow negative order line total after applying promotions" to True.

2. In case you need the AwardAmount value for reference post cancellation, extend YFS_Promotion_Award with a column such as faceValue or initialCouponValue and have this updated whenever a coupon is applied to an order. This would give you a column for getOrderDetails to pull
the real face value of the coupon later on.

3. Another way to obtain this value post cancellation is to stamp the coupon value in order notes before cancelling the lines.

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Document Information

Modified date:
16 June 2018

UID

swg21992533