IBM Support

Automatic view encounters an error when an element has been removed under certain circumstances

Troubleshooting


Problem

An attempt to use an automatic view results in an error when an element has been removed in a situation that is related to the timing of the rmelem operation. If you are using ClearTeam Explorer, an I/O device error is displayed; if you are using an operating system command, an access error is displayed.

Cause

An automatic view reads a directory in two steps:

  1. The view verifies the existence of the directory and its contents.
  2. The view requests further details about the directory.

If an element is removed (for example, by rmelem) between these two steps, an error like one of those described above is displayed.

Resolving The Problem

Updating the view resolves the problem. If you would prefer not to update the view,

  • Restore the object that has been removed (Refresh > Repair discordance). This operation causes the view to recognize that the object no longer exists.
  • If restoring the file system object is ineffective at resolving the problem, restore the parent directory of the object. This operation causes the view to recognize that the object has been uncataloged from its parent.
  • If restoring the parent directory is ineffective, update the view.

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Document Information

Modified date:
08 August 2018

UID

swg21697515