IBM Support

Attempting to upload data from any file fails: MSR_GEN_0038 canUploadFiles

Troubleshooting


Problem

When attempting to upload data from a file e.g. CSV, Excel, it fails with an error...

Symptom

{"msg":"MSR_GEN_0038 User does not have have capability: canUploadFiles"}

Cause

The /drivers subdirecory contained spurious files.

Resolving The Problem

The only files that should be contained in the /drivers subdirectory are the drivers.txt file and the jdbc drivers required to access the Cognos Analytics content store database and reporting databases.

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21998232