Troubleshooting
Problem
Attempting to access the Sterling Business Center display an "An error has occurred" message
Symptom
Cannot login to the Sterling Business Center (SBC)
Cause
Improperly configured web.xml file.
Diagnosing The Problem
Review the messages.log file for an error of:
SECURITY-FAILURE - Input does not conform to pattern: context=Cookie value (Name:userContext)0|in|0, pattern=^[a-zA-Z0-9.!\\-\\\/+=_ :\\^]*$input=0|in|0\n ValidationException @ com.sterlingcommerce.security.dv.SCValidationException
Resolving The Problem
- Update the web.xml in the <runtime_sandbox>/repository/eardata/sbc/extn directory with the below entry.
<context-param>
<param-name>scui-consider-application-cookies-only</param-name>
<param-value>true</param-value>
</context-param>
Document Location
Worldwide
[{"Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"ARM Category":[{"code":"a8m0z000000cy01AAA","label":"Performance"}],"ARM Case Number":"TS004898825","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]
Product Synonym
OMS;SBC;Business Center
Was this topic helpful?
Document Information
Modified date:
03 February 2021
UID
ibm16411261