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Archive restore fails to import file with message "Cannot find zip file" even if the file exists.

Troubleshooting


Problem

Archive restore fails to import file with message "Cannot find zip file" even if file exists. The file was copied over from archive server to the guardium appliance.

The archive type is SCP.

Symptom

- Archive restore fails.

- You're using SCP method of archive.

- You can see the message "Cannot find zip file" for example in detailed log, or debug, log in aggregation/archive report.

- You also noticed that the file is on the appliance already.

- If you look at the archive server the file is there and the permission of the file is 600

Cause

On the archive server the archive file need to have permission 644. Most likely you got a security setting that change the file permissions from 644 to 600.

If you configure archive to use SCP and user X then the Guardium appliance SCP command is using user X to get the file, so that works ok.  But TAKE NOTE! the restore in guardium is not done by user X but by another user Y. If permissions on file is 600 then the user Y can't read the file.

Resolving The Problem

Before you do the restore change permissions on files that you want to restore to 644.

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Component":"archive;restore","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"v9, v9.5, v10.0,v10.1,v10.5,v10.6","Edition":"All","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
25 October 2018

UID

ibm10737375