Troubleshooting
Problem
In WebSphere Application Server Liberty Profile 8.5.5.4, if a user updates a class with annotations, the server may not recognize the change(s). This can result in unexpected behavior in a development environment.
Symptom
When an annotation is added/removed/modified and that change is published to the server, the server will not react to the change appropriately (by either restarting the application or by changing the application's behavior). The server will print a message similar to this in these cases:
CWWKZ0062I: The MyApp application has been updated, but not restarted.
Cause
The server attempts to avoid restarting applications on minor changes, but is too aggressive in this case - where the user only changes annotations.
Environment
Typically, this only occurs in a development environment, but it is also possible for this problem to occur when replacing individual class files expanded on disk in the server's application directories (i.e. apps, dropins, etc.)..
Diagnosing The Problem
If you see the following message in your log output after only changing a class's annotations (or making annotation changes in addition to minor changes to a class's method body), then you have encountered this problem:
CWWKZ0062I: The MyApp application has been updated, but not restarted.
Resolving The Problem
This problem is fixed in the version of Liberty 8.5.5.4 that is available on the wasdev.net (IBM developerWorks) web site. If your version of the Liberty 8.5.5.4 product was acquired by other channels (i.e. Passport Advantage, InstallManager, etc.), then you will need to apply an interim fix for this problem - the ifix will be available shortly and will be listed with the APAR PI30922.
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Document Information
Modified date:
15 June 2018
UID
swg21692254