Troubleshooting
Problem
The application requester cannot establish the connection
Symptom
SQLException with the message "The application requester cannot establish the connection"
Cause
The Toolbox JDBC driver uses the system name, user ID, and password provided in the call to DriverManager.getConnection() to establish a connection to the IBM i database, Wrong information or Database of host server is not start can cause toolbox JDBC driver can not sign on to the system.
Resolving The Problem
- Verify the system name . One way to verify this is to use ping with the specified system name. If ping fails, then there is a TCP/IP configuration problem between your client and the system.
- Verify the user ID or password.
- Verify the IBM i database host server is started. You can start this by running STRHOSTSVR *DATABASE on the IBM i command line. You can verify if the IBM i database host server is running using the utilities.JPing application.
You can get more information about the exception by turning on JDBC tracing.
Document Location
Worldwide
[{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG60","label":"IBM i"},"Component":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB57","label":"Power"}}]
Product Synonym
IBM i;AS400
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Document Information
Modified date:
17 March 2020
UID
ibm11118043