IBM Support

Application Manager throws ClassNotFoundException

Troubleshooting


Problem

Attempts to open application manager in IBM Sterling Order Management leads to the java.lang.ClassNotFoundException error.

Symptom

Upon Opening a customized screen in Application manager the ClassNotFoundException is seen in application manager.
-------------------
<Error ErrorCode="java.lang.ClassNotFoundException"
ErrorDescription=""
ErrorRelatedMoreInfo="com.oms.smcfs.appManager.ui.forms.Custom
ingGuideLineDtl">
-------------------

Cause

yfsextn.jar is not configured appropriately.

Diagnosing The Problem

The OOTB UI Jars are marked 'trusted libraries' so that applet does give warnings about these jars.
However, as a security measure, the applet does not seem to allow class lookup of class files which are not marked trusted.

Resolving The Problem

To resolve, add the below attribute in the MANIFEST.MF file of the yfsextn.jar

Trusted-Library: true

Typically if jar is build using net beans IDE, it may add this attribute, if not, then it can be added manually into the manifest file before signing the jar.

NOTE:
Jar signing certificates are secret like passwords. Its unlikely for product to share these certificates.

You can continue to sign with your own self signed certificate. Ensure that you should add trusted library in their meta-inf file.

Related Information

[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Documentation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
11 February 2020

UID

swg21962259