IBM Support

Application failed to initialize properly (0X80000003) when launching Firefox in RPT 8.5

Troubleshooting


Problem

On Windows Server 2003 64-bit, launching Firefox to record a HTTP protocol test results in "Application error - The application failed to initialize properly (0X80000003). Click on OK to terminate the application".

Symptom



Cause

This has been identified as a product defect under APAR PM97559

Environment

Only on Windows Server 2003 64-bit

Resolving The Problem

This has been identified as a product defect. The work around is

1. Choose Unmanaged Application when recording.
2. Use the default Proxy Recorder Settings, like below. Note the Proxy port.



3. Start Firefox manually.
4. Modify Firefox (Tools->Options->Advanced->Network->Settings) so that it uses this Proxy port:



5. In Firefox, go to the desired URL and interact with the application as normal.
6. Exit from Firefox.
7. Stop the recording (using the blue button):

[{"Product":{"code":"SSMMM5","label":"IBM Rational Performance Tester"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Record \/ Author tests","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5;8.5.0.1;8.5.0.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21651441