IBM Support

Apphost failed running due to sync error

Troubleshooting


Problem

After upgrade Apphost or add a new app node, it fails to running due to the following error
Warning FailedMount 52m (x4 over 53m) kubelet MountVolume.SetUp failed for volume "config-volume" : failed to sync configmap cache: timed out waiting for the condition Warning FailedMount 52m (x5 over 53m) kubelet MountVolume.SetUp failed for volume "custom-config-volume" : failed to sync configmap cache: timed out waiting for the condition Warning FailedMount 43m (x4 over 43m) kubelet MountVolume.SetUp failed for volume "config-volume" : failed to sync configmap cache: timed out waiting for the condition Warning FailedMount 43m (x4 over 43m) kubelet MountVolume.SetUp failed for volume "custom-config-volume" : failed to sync configmap cache: timed out waiting for the condition

Symptom

See the following error:
Warning  FailedMount  52m (x4 over 53m)  kubelet  MountVolume.SetUp failed for volume "config-volume" : failed to sync configmap cache: timed out waiting for the condition
  Warning  FailedMount  52m (x5 over 53m)  kubelet  MountVolume.SetUp failed for volume "custom-config-volume" : failed to sync configmap cache: timed out waiting for the condition
  Warning  FailedMount  43m (x4 over 43m)  kubelet  MountVolume.SetUp failed for volume "config-volume" : failed to sync configmap cache: timed out waiting for the condition
  Warning  FailedMount  43m (x4 over 43m)  kubelet  MountVolume.SetUp failed for volume "custom-config-volume" : failed to sync configmap cache: timed out waiting for the condition
>>> App Host xxxx (apphostsoar, version 1.15.1.1) <<<
- [error] Component synchronizer is not ready

Cause

Possible Reasons cause this issue:
-DNS name has been changed, need to upgrade or register via
manageAppHost dns --set --ip <ip_address> --hostname <newhostname> --hostname <newhostname>
-Cache issue, Need to restart AppHost and K3S service to fresh via
sudo systemctl restart k3s
sudo restartAppHost
-In the new env, firewall not open

Environment

Any

Resolving The Problem

If DNS has been changed, after update it in etc/hosts file and register via
manageAppHost dns --set --ip <ip_address> --hostname <newhostname> --hostname <newhostname>
Do the following to fresh:
Restart  coredns pod to make the DNS config update
kubectl rollout restart deploy coredns -n kube-system
deployment.apps/coredns restarted
Restart Apphost and k3 service:
sudo systemctl restart k3s
sudo restartAppHost
Make new synchronizer running may needed:
deployment.apps/deployment-synchronizer restarted
deployment.apps/deployment-operator restarted
Restart SOAR resilient-messaging.service and resilient-app-manager.service may needed:
sudo systemctl restart resilient-messaging.service
sudo sysyemctl restart resilient-app-manager.service
If it due to firewall communication, need to make sure in the new env has following:
sudo firewall-cmd --permanent --zone=trusted --add-interface=cni0 &&

sudo firewall-cmd --permanent --zone=trusted --add-interface=flannel.1 &&

sudo firewall-cmd --permanent --zone=trusted --add-port=443/tcp &&

sudo firewall-cmd --permanent --zone=trusted --add-port=6443/tcp &&

sudo firewall-cmd --permanent --zone=trusted --add-port=10250/tcp

Document Location

Worldwide

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Document Information

Modified date:
29 March 2024

UID

ibm17145544