IBM Support

APM 8.1 : NT AGENT MISSING IN APM GUI CONSOLE

Troubleshooting


Problem

NT AGENT is not shown in APM GUI dashboard console

Symptom

From agent Log like <MY_SYSTEM_NAME>_nt_kntcma_<timestamp>.log  it shows:
kraacthi.cpp,1048,"parseXMLfile") <0x36E3740,0x0> Parsing Error: no element found in C:\IBM\APM\localconfig\nt\nt_asfSubscription.xml, line 1:

kraacthi.cpp,1070,"parseXMLfile") *P-INFO: error attempting to rename C:\IBM\APM\localconfig\nt\nt_asfSubscription.xml to C:\IBM\APM\localconfig\nt\nt_asfSubscription.xml_parseError

kraaomsg.cpp,1033,"IRA_outputAgentMessage") *SFCP-INFO: Agent Subscription Facility initialized.

Cause

We suspect someone manually modified the file: nt_asfSubscription.xml.

Environment

Microsoft Windows Server 2012 R2 Standard with APM 8.1 NT AGENT version 6.35.14.03
APM SERVER version 8.1.4.0-IBM-APM-SERVER-IF0007

Diagnosing The Problem

Check and review if the nt_asfSubscription.xml file [e.g. C:\IBM\APM\localconfig\nt\nt_asfSubscription.xml ] is empty.

Resolving The Problem

The reason that agent is not sending data is because its asf subscription file is empty.
To recover your NT Agent, erase the file C:\IBM\APM\localconfig\nt\nt_asfSubscription.xml and restart the NT agent.

Document Location

Worldwide

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSVJUL","label":"IBM Application Performance Management"},"Component":"KNT AGENT","Platform":[{"code":"PF033","label":"Windows"}],"Version":"06.35314.03","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

APM;Application Performance Management;

Document Information

Modified date:
05 February 2020

UID

ibm10885909