Troubleshooting
Problem
![image-20221228140636-1](/support/pages/system/files/inline-images/image-20221228140636-1.png)
Cause
2.) The apikeytoken table is corrupted
Resolving The Problem
Go to Security > Security Groups. Search for MAXADMIN group.
On the Applications tab under Applications, filter for Description=Administration and Application Type=Work Center.
Click Object Structure Authorizations (in some environments you need to list actions to get this option):
Grant Delete, Insert, Read, Save, as well as "Sigoption to control the visibility of SQL clause in apimeta and querymeta" for MXAPIAPIKEY.
Save the changes, log out, and log back in. Then, test again.
If the permissions are granted and you still see the issue, maybe apikeytoken table is corrupted:
2.) Truncate APIKEYTOKEN table in Manage database:
TRUNCATE TABLE APIKEYTOKEN IMMEDIATE;
COMMIT;
cd /opt/IBM/SMP/maximo/tools/maximo
./insertapikey.sh -v'${MANAGE_APIKEY}' -m'prop:mxe.int.dfltuser'
./insertapikey.sh -v'${MANAGE_APIKEY}, O=cert-manager' -m'prop:mxe.int.dfltuser'
./insertapikey.sh -v'${HEALTH_APIKEY}' -m'prop:mxe.MASUserSyncAgentUser'
./insertapikey.sh -v'${HEALTH_APIKEY}, O=cert-manager' -m'prop:mxe.MASUserSyncAgentUser'
./insertapikey.sh -v'${PMI_APIKEY}' -m'prop:mxe.PMIUser'
./insertapikey.sh -v'${PMI_APIKEY}, O=cert-manager' -m'prop:mxe.PMIUser'
./insertapikey.sh -v'${PMI_APIKEY_NEW}, O=cert-manager' -m'prop:mxe.PMIUser'
./insertapikey.sh -v'${PMI_APIKEY_NEW}' -m'prop:mxe.PMIUser'
./insertapikey.sh -v'${EU_APIKEY}' -m'prop:hputilities.health.user'
./insertapikey.sh -v'${EU_APIKEY}, O=cert-manager' -m'prop:hputilities.health.user'
./insertapikey.sh -v'${EU_APIKEY_NEW}, O=cert-manager' -m'prop:hputilities.health.user'
./insertapikey.sh -v'${EU_APIKEY_NEW}' -m'prop:hputilities.health.user'
Document Location
Worldwide
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Document Information
Modified date:
28 December 2022
UID
ibm16851991