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API Invoke policy persistent idle timeout

Question & Answer


Question

How do I configure the API Invoke policy persistent idle timeout?

Cause

There is no persistent idle timeout setting visible in the Invoke policy or in the knowledge center.  I need to know what it is configured to by default and if I can change the invoke persistent timeout.

Answer

The Invoke policy endpoint when persistent connections are enabled will check and try to close the persistent idle connection after at most 32 seconds.
A persistent idle connection could be closed in as quickly as 16 seconds.

As in many other technotes, the suggestion is to allow the client side of the connection. In this case the Invoke policy running on the gateway is to close the connection first.
IF the endpoint has a low persistent timeout, then you can experience connection failures when the Invoke tries to reuse the connection only to find the server/endpoint trying to close.
Always have the server side persistent timeout greater than the client so that any Invoke endpoints using persistent connections should have an idle persistent timeout greater than 32 seconds.

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Document Information

Modified date:
14 November 2023

UID

ibm17073503