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IZ99289: CEC AGENT DOESN'T DISPLAY DATA IF RUN AS NON-ROOT AND STARTED FROM TEPS.

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You can track all active APARs for this component.

 

APAR status

  • Closed as program error.

Error description

  • Detailed Recreation Procedure:
    - login as an non-root user
    - install ux and pk agent as non-root user in the same candle
    home.
    - after configuring $candlehome/bin/Setperm as root.
    - then start the pk agent from the teps.
    .
    The data will not be displayed.
    .
    Related Files and Output:
    HMCQuery.c
    .
    Root cause:
    The execution of the key.pl -q in shell command didn't return
    data for non-root started from teps.
    

Local fix

Problem summary

  • ****************************************************************
    *****
    * USERS AFFECTED: All users running the agent as non-root.
    ****************************************************************
    *****
    * PROBLEM DESCRIPTION: If the agent is installed with a non-root
    * user ID, then the agent does not return data when remotely
    * started from the Tivoli Enterprise Portal.
    ****************************************************************
    *****
    * RECOMMENDATION: Apply 6.2.2.1-TIV-ITM_CEC_BASE-IF0002.
    ****************************************************************
    *****
    Interim Fix 6.2.2.1-TIV-ITM_CEC_BASE-IF0002
    resolves the problem by allowing data to be collected as
    non-root
    when started remotely.
    

Problem conclusion

  • The fix for this APAR is contained in the following maintenance
    package:
    
       | interim fix | 6.2.2.1-TIV-ITM_CEC_BASE-IF0002
    

Temporary fix

Comments

APAR Information

  • APAR number

    IZ99289

  • Reported component name

    ITM SE SYSP CEC

  • Reported component ID

    5724C04CB

  • Reported release

    622

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2011-04-21

  • Closed date

    2011-06-24

  • Last modified date

    2011-06-24

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    ITM SE SYSP CEC

  • Fixed component ID

    5724C04CB

Applicable component levels

  • R622 PSY

       UP

[{"Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTFXA","label":"Tivoli Monitoring"},"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"622"}]

Document Information

Modified date:
30 December 2022