IBM Support

ANS1092W error with restore operation using non-root user.

Troubleshooting


Problem

Running a client restore as a non-root user logs the ANS1092W error. The same restore using root userid is successful.

Symptom

Using a root and non-root userid, the same "dsmc query backup" command returns different results.

As root: :

dsmc query backup -ina /filespace/dir/

Size Backup Date Mgmt Class A/I File
---- ----------- ---------- --- ----
4,096 B 01/28/13 14:02:11 standard A /filespace
256 B 01/28/13 14:02:11 standard A /filespace/dir


As user1:

dsmc query backup -ina /filespace/dir/
...
ANS1092W No files matching search criteria were found
...

Cause

The owner of a Tivoli Storage Manager client backup is the owner of the file or directory when the backup was done. This ownership is stored in Tivoli Storage Manager server database. Only the owner or root has the permission to restore the data. The other non-root authorized user can also do the restore but need to use the -fromowner option.

Resolving The Problem

Use the following steps to resolve this issue.
1. Logon with the root userid and provide the non-root user permission to restore data. For example :

dsmc set access backup /filespace/dir/*/* user1
dsmc set access backup /filespace/dir/* user1

2: Perform restore:
dsmc restore /filespace/dir/ -fromowner=root [

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Client","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21632570