Troubleshooting
Problem
ANR8311E errors are seen in the Activity log, when there are no hardware related issues.
Symptom
During normal processing the following errors may be seen for a limited time:-
ANR8311E An I/O error occurred while accessing drive DRIVE1 (mt0.0.0.1) for QUERYAPPENDONLY operation, errno = 3, rc = 2863.
ANR8311E An I/O error occurred while accessing drive DRIVE1 (mt0.0.0.1) for RELEASE operation, errno = 3, rc = 2863.
Errno = 3 is a Windows error meaning "ERROR_PATH_NOT_FOUND"
and RC = 2863 means "IO_FAILURE"
During the times when these errors occur the drives can be seen using TSMDLST or ITDT.
Cause
Windows Group Policy update is causing the IBM Spectrum Protect server to lose contact with the drives.
Environment
This behaviour was observed on server version 7.1.6.0 on Windows, but could affect other versions.
Diagnosing The Problem
Check the Windows Application Event Log and just before the ANR8311E for this message:
Information Date Time SceCli 1704 None Security policy in the Group policy objects has been applied successfully.
For example:
Error Date Time ADSMServer 21 (8311) TSM Server Error: Server: TSM-01 ANR8311E An I/O error occurred while accessing drive DRIVE1 (mt0.0.0.1) for RELEASE operation, errno = 3, rc = 2863.
Error Date Time ADSMServer 21 (8311) TSM Server Error: Server: TSM-01 ANR8311E An I/O error occurred while accessing drive DRIVE1 (mt0.0.0.1) for QUERYAPPENDONLY operation, errno = 3, rc = 2863.
Information Date Time ADSMServer 19 (1626) TSM Server Information: Server: TSM-01 ANR1626I The previous message (message number 2034) was repeated 153 times.
Information Date Time SceCli 1704 None Security policy in the Group policy objects has been applied successfully.
To confirm whether you are seeing this issue run the "gpupdate /force" command manually while drives are in use and see if the above ANR8311E errors occur.
Resolving The Problem
You can prevent the issue by removing IBM Spectrum Protect server from active directory group policy.
Alternatively, the following Microsoft patches may also cause the issue. Removing them can also stop the tapes from receiving the “PATH NOT FOUND” error:
KB4338824
KB4284878
KB4056898
KB4457143
KB4093115
KB4074597
KB4088879
Was this topic helpful?
Document Information
Modified date:
17 December 2018
UID
swg22009960