IBM Support

analytics events:cloudCount fails with Invalid mode specified [analytics]. Must be one of [ apicatalog, apim, consumer, portaladmin ].

Troubleshooting


Problem

The following error is reported: 
./apic -m analytics events:cloudCount --server cloud.mgmt.dev.apictenlts.ibmlab.test --analytics-service analytics --format json
Invalid mode specified []. Must be one of [ apicatalog, apim, consumer, portaladmin ].

Cause

The version of toolkit is old where the analytics mode is not present and/or does not match with the management or analytics server version. 

Resolving The Problem

Download the correct toolkit version from the management server where you are connecting to get the data.
For this particular usecase, user was using 10.0.4.0-ifix3 toolkit to connect to 10.0.5.3 server. After downloading the 10.0.5.3 toolkit the command succeeded. 

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSMNED","label":"IBM API Connect"},"ARM Category":[{"code":"a8m50000000CeBlAAK","label":"API Connect-\u003EManagement and Monitoring (MM)-\u003EAnalytics"}],"ARM Case Number":"TS014317231","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"10.0.5"}]

Document Information

Modified date:
03 October 2023

UID

ibm17046039