Troubleshooting
Problem
Attempts to create an Exchange Ordre displays the Amount transferred as $0 on payment confirmation page in IBM Call Center for Commerce (CCC) application.
Symptom
Steps to simulate:
- Create a sales order and take it to Shipped and PAID status.
- Create a return order using API tester and with flag ProcessPaymentsOnReturnOrder = N.
- Create an Exchange Order using return order's order header key using API tester.
- Now open this order in CCC and traverse till payment confirmation page.
It shows below message :
Money transferred into sales order
Amount transferred: $0.00
Cause
Return order is created using attribute ProcessPaymentsOnReturnOrder as 'N'
Diagnosing The Problem
This complete flow works with ProcessPaymentsOnReturnOrder =Y and issue happens only when you customize the mashup to pass ProcessPaymentsOnReturnOrder=N.
Resolving The Problem
Steps to resolve:
- If ProcessPaymentsOnReturnOrder =N is set then to view the transferred amount, you will have to create the return order invoice and also complete the return payment processing before moving to payment confirmation screen.
- To view the transferred Amount, customize and hide OOTB Data label "Amount Transferred".
- Add a new data label similar to above and change the source binding as below :
Source :
NameSpace : exchangeOrderTotal_Output
Path : Order.ChargeTransactionDetails.TotalTransferredIn
Currency :
nameSpace : paymentConfirmation_getCompleteOrderDetails_Output
Path : Order.PriceInfo.Currency
[{"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.4","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]
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Document Information
Modified date:
16 June 2018
UID
swg21999261