IBM Support

alert is trigged by wrong rule

Troubleshooting


Problem

Rules were created but alert is being triggering by the wrong rule.

Symptom

Case 1:
We tried "MQMFT.Originator.Hostname" parameter for comparing "originator Server"
There are 3 instances of the Key name "MQMFT.Originator.Hostname" as Z/OS server names (server1 and server2 and server3) this is using the rule "MQMFTCorpXferFailed" instead of using "MQMFTMainframeCorpXferFailed"

Case 2:
We tried "MQMFT.User Provided Metadata" parameter for comparing "originator Server". Metadata userdata1 is mapped to "MQMFT.Originator.Hostname" When we use 3 instances of"originator Server" set to "does not match" ZOS server names (server1 and server2 and server3) this is using the rule "MQMFTMainframeCorpXferFailed" instead of using "MQMFTCorpXferFailed"

Cause

Incorrect rule configuration

Diagnosing The Problem

review rule configuration

Resolving The Problem

For MQMFTMainframeCorpXferFailed rule, for the Key MQMFT.originator.hostname the Operator would be RegEx and the Value would be server|server2|server3

Have this at the top and the MQMFTCorpXferFailed rule does not have to have this Key."

[{"Product":{"code":"SS9GLA","label":"IBM Control Center"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"6.1.0.1;6.0.0.1;5.4.2.1","Edition":"All Editions","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 December 2019

UID

swg22008536