Question & Answer
Question
AirGap環境にILMTサーバー/BigFixサーバーを構築しています。
定期的に AirgapTool でサイトのコンテンツを更新する運用をしているにも関わらず、アクションを実行するとダウンロード・エラーになり、AirgapTool の再実行を余儀なくされることがあります。
その運用工数を減らすには、どのような対策をとればよいですか。
Cause
AirGap環境のアクションのダウンロード・エラーは、BigFixサーバー上のコンテンツのキャッシュ・ファイルが不足したため発生します。
Answer
AirGap環境では、BigFixコンソールから「スキャナーのインストールまたはアップグレード」等のアクションを実行すると、必要となるプログラムファイルをBigFixクライアントにダウンロードして実行させることがあります。
そのようなプログラムファイルは、BigFixサーバーから「キャッシュファイル」がBigFixクライアントに伝播されて生成されます。
「キャッシュファイル」は、外部インターネット接続可能端末でお客様にて AirgapTool を実行いただいた結果、サイトのコンテンツ(AirgapResponse)とあわせてダウンロードし、転送いただいたファイルです。
BigFixサーバー上の次のディレクトリにあります。
<キャッシュファイル配置ディレクトリ>
Windows: C:¥Program Files (x86)¥BigFix Enterprise¥BES Server¥wwwrootbes¥bfmirror¥downloads¥sha1
RHEL: /var/opt/BESServer/wwwrootbes/bfmirror/downloads/sha1
AirGap環境でこのキャッシュファイルが不足すると、BigFixサーバーは外部インターネットにアクセスして不足したファイルをダウンロードしようと試みて失敗するため、ダウンロード・エラーが発生します。
<キャッシュファイルが不足する要因>
BigFixサーバーは、基本仕様として、外部インターネットにアクセスし、コンテンツやキャッシュファイルを自動でダウンロードします。
そのため、ファイルシステムの圧迫を防ぐ目的で、キャッシュファイル配置ディレクトリのキャッシュファイルを定期的に古いファイルから削除します。
キャッシュファイルを削除しても、アクション実行時に不足するキャッシュファイルがあれば、自動で外部インターネットにアクセスしダウンロードして補います。
しかし、AirGap環境では、外部インターネットアクセスができないため、自動でキャッシュファイルをダウンロードして補うことができません。
そこで、AirgapTool を実行し、手動でキャッシュファイルをダウンロードして、補う必要があります。
<キャッシュファイル不足の対策>
AirGap環境でダウンロード・エラーが発生した場合は、再度、AirgapTool を実行して、不足したキャッシュファイルをダウンロードし、sha1 ディレクトリに配置することが必要となります。
運用上、3つの対策が考えられます。
1. キャッシュファイルの sha1 ディレクトリの上限値をできるだけ拡張する
sha1 ディレクトリには上限値が設けられており、上限を超えるキャッシュファイルは削除される仕様です。そのため、sha1ディレクトリの上限値を可能な限り拡張することをお勧めします。
sha1ディレクトリの上限値"_BESGather_Download_CacheLimitMB"の確認方法:
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1. BigFixコンソールにログインします。
2. 左ナビゲーション・ツリーより「コンピューター」をクリックします。
3. コンピューター一覧より BigFix サーバのあるマシンを右クリックします。
4. メニューから「コンピューター設定の編集」をクリックします。
5. カスタム設定項目の一覧から"_BESGather_Download_CacheLimitMB"の値を確認します。
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ILMTの用途では導入時に 2048 (約2GB)程度を推奨しておりますが、さらに1~2GBは追加されてもよろしいかと思われます。もしBESSupportサイトのアクションをご利用の場合はさらに必要となります。
尚、この上限値設定を拡張しても、キャッシュファイルの削除は完全には防止できません。ファイルサイズが上限値に達していない場合でも、BigFixの内部処理の判断により、キャッシュファイルが削除される場合がありますので、下記の2. 3. の対策も併せてご実施ください。
2. AirgapTool を実行してダウンロードしたキャッシュファイルをバックアップしておく
AirgapTool 実行によりダウンロードしたキャッシュファイルを、sha1ディレクトリとは別ディレクトリにバックアップしておくことをお勧めします。
アクション実行により不足したキャッシュファイル名は、アクションの実行画面のダウンロード・エラーの詳細画面に表示されます。
そこで、不足したキャッシュファイルを、バックアップしたキャッシュファイルからsha1ディレクトリにコピーして補うことで、アクションを実行できるようになります。
3. 不足したキャッシュファイルのみURLから直接ダウンロードする
アクションの実行時、ダウンロード・エラーの詳細画面には、不足したファイルの名称と、キャッシュファイル名、および、ダウンロードURLが表示されます。
そこで、該当URLに外部インターネット接続可能端末からアクセスし、不足したファイルのみを直接ダウンロードすることができます。
ダウンロードしたファイルは、そのままでは利用できないため、キャッシュファイル名にリネームして、sha1 ディレクトリに配置ください。
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Document Information
Modified date:
26 April 2021
UID
ibm10729150