Troubleshooting
Problem
The Alert Viewer UI is failing with the error: "UNKNOWN ERROR", and the required alerts are not showing up in the Alert Viewer.
Symptom
Observed when there are large number of standing alerts (Over 100k) in the database.
Cause
By default when you load the alert list, it uses the
All alerts
filter, which tries to fetch all the alerts together at the same timeEnvironment
CPWAIOps, OCP Versions: 4.3, 4.12.10
Diagnosing The Problem
Due to timeout when Datalayer tries to fetch the required alerts from Postgres, after 30 seconds.
Resolving The Problem
To overcome this problem, append
filtername
parameter to the alerts page URL and use the filter that can fetch reduced number of alerts.<Valid URL reference here> https://<host>:<port>/aiops/<tenantId>/resolution-hub/alerts?filtername=<your filtername>
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSE9G0Q","label":"IBM Cloud Pak for AIOps"},"ARM Category":[{"code":"a8m3p000000PCISAA4","label":"Watson AIOps-\u003EAI Manager-\u003EAlert Viewer-\u003EAlerts"}],"ARM Case Number":"TS014951834","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
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Document Information
Modified date:
08 January 2024
UID
ibm17105480