Troubleshooting
Problem
Attempts to run agents/integration servers leads to the Error ErrorCode="java.lang.reflect.InvocationTargetException" in IBM Sterling Order Management.
Symptom
The complete error is:
<Error ErrorCode="java.lang.reflect.InvocationTargetException"
ErrorDescription="Error_description_not_available"
ErrorRelatedMoreInfo="" ErrorUniqueExceptionId="172.16.232.5514499400272980000000004827">
<Attribute Name="ErrorCode" Value="java.lang.reflect.InvocationTargetException"/>
<Attribute Name="ErrorDescription" Value="Error_description_not_available"/>
<Error ErrorCode="java.lang.reflect.InvocationTargetException" ErrorDescription="" ErrorRelatedMoreInfo="">
Cause
This error is a symptom of jar mismatch or a potential deployment issue.
Resolving The Problem
Ensure that the Agent configuration file (AgentDynamicClassPath.cfg) does not have duplicate entries for jars containing the same class.
For example:
The duplicate entry in this case was:VENDOR_JAR=/opt/IBM/Sterling93/jar/websphere/85/com.ibm.jaxrs.thinclient_8.5.0.jar
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Document Information
Modified date:
16 June 2018
UID
swg21973927