Troubleshooting
Problem
When trying to synchronize a node, the following errors are seen in the nodeagent SystemOut.log:
Symptom
ADMD0012E: Unable to initialize the transport of type: TCP
ADMS0012E: Unable to create administrative client connection:
com.ibm.websphere.management.exception.AdminException: Admin client connection to deployment manager is unavailable
Cause
The NODE_DISCOVERY_ADDRESS port is in use by another process, either by WebSphere®, the operating system, or another application.
Resolving The Problem
Open up the node's serverindex.xml file located in <WAS_HOME>/config/cells/<cellname>/nodes/<problem node> directory and search for the NODE_DISCOVERY_ADDRESS port:
<specialEndpoints xmi:id="NamedEndPoint_1121896486996" endPointName="NODE_DISCOVERY_ADDRESS">
<endPoint xmi:id="EndPoint_1121896486999" host="hostname" port="7272"/>
Stop the node and issue a netstat or netuse to see a list of ports in use on the nodeagent box. If the port, in this case, 7272 displays as in use, LISTENING, then there is another process using the port.
Change the nodeagent discovery port to one not listed in the netstat so the nodeagent can work properly. This is done by modifying the master configuration and then synchronizing.
Follow these steps:
- Open the problem serverindex.xml on the ND install located in <WAS_ND>/config/cells/<cellname>/nodes/<problem node>
- Edit the NODE_DISCOVERY_ADDRESS port to an open port number
- Save the manual changes
- Start or make sure the dmgr process is running
- Synchronize with nodes using the syncNode script located on the BASE installs bin directory
Now, the node can synchronize with the dmgr.
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Document Information
Modified date:
15 June 2018
UID
swg21213288