Troubleshooting
Problem
分散環境で、Cognos Analytics が稼働しているマシンに複数のネットワークアダプターが存在するため、マニュアル「設定グループ (Configuration Group)」の管理の手順に従い、「メンバー調整ホスト」に具体的な IP アドレスを設定して Cognos Analytics を起動したところ、Cognos ポータルにサインイン後に以下のエラーが発生し、Cognos ポータルが使用できません。
Symptom
![image-20220927093623-1](/support/pages/system/files/inline-images/image-20220927093623-1.png)
Cause
IBM Cognos Configuration の「セキュリテイ」>「暗号化」> 「Cognos」下の「件名代替名」>「IPアドレス」に、空白や別の IP アドレスが設定されていることが原因です。
Diagnosing The Problem
- IBM Cognos Configuration の「セキュリテイ」>「暗号化」を右クリックして「テスト」を実施すると、「件名代替名の確認」がエラーとなります。
![image-20220927094347-2](/support/pages/system/files/inline-images/image-20220927094347-2.png)
- 別の設定方法である bootstrap.properties ファイルを使用したパターンマッチング方法では、この問題は発生しません。
Resolving The Problem
「メンバー調整ホスト」に具体的な IP アドレスを設定したい場合は、以下の手順を実施します。
- IBM Cognos Configuration を起動します。
- 「セキュリテイ」>「暗号化」> 「Cognos」下の「件名代替名」>「IPアドレス」に、「メンバー調整ホスト」と同じ IP アドレスを設定します。
- 「セキュリテイ」>「暗号化」を右クリックして「テスト」を実施(「保存」が促されます。)し、エラーが発生しないことを確認します。
- Cognos Analytics を再起動します。
Related Information
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl6sAAC","label":"Install-\u003EConfigure"}],"ARM Case Number":"TS010422668","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
Was this topic helpful?
Document Information
Modified date:
26 September 2022
UID
ibm16824101