Troubleshooting
Problem
「ソフトウェア・スキャンの開始」タスクが実行できない
Symptom
ILMT サーバーを構築して、BigFix クライアント、およびスキャナーを監視対象のコンピュータにインストールしました。
次に、BigFix コンソールから「ソフトウェア・スキャンの開始」タスクを実行しようとしたところ、「アクションの実行」ボタンを押した後に、「対象」タブに該当のコンピュータが表示されません。
あるいは、「ソフトウェア・スキャンの開始」タスクがグレーアウトしています(該当タスクが実行可能な対象コンピュータが1台もない場合)。
確認したところ、BigFix コンソールで、「Catalog Download」タスクが完了状態となっていませんでした。
概要部分を確認すると以下のエラーが発生しています。
"HTTP Error 28:Timeout was reached:Operation timed out after 10000 millseconds with 0 out of 0 bytes received"
Cause
「ソフトウェア・スキャンの開始」の前提条件として、「Catalog Download」タスクが実行されている必要があります。
「Catalog Download」タスクは、BigFix サーバーが ILMT サーバーからカタログファイルをダウンロードし、BigFix クライアントに配布する処理で、通常はスキャナーが導入されたクライアントに対して自動的に実行されています。
しかし、BigFix サーバーがインターネット接続するためにプロキシーが設定されている環境では、BigFix サーバーは ILMT サーバーに直接接続するのではなく、プロキシーに接続してしまい、処理が失敗します。
Environment
ILMT 9.x
Diagnosing The Problem
ILMT 9.x / BigFix 9.5 サーバーをプロキシーのある環境に構築し、BigFix サーバーのプロキシーの例外設定に ILMT サーバーが指定されていない場合、上記の問題が発生します。
Resolving The Problem
プロキシーの例外設定に ILMT サーバーを追加することによって、現象が改善します。
手順は以下です。
<Windows>-------------------------
1) BigFix サーバーのある環境にて、コマンドプロンプトより以下を実行します。
C:\Program Files (x86)\BigFix Enterprise\BESServer\BESAdmin /setproxy
2) プロキシー設定画面が開くので、「例外リスト」にカンマ区切りで ILMT サーバーのホスト名、IPアドレスを追加します。
例:localhost, 127.0.0.1, ILMTserverHostname, ILMTserverIPアドレス
3) 設定後、ILMT/BigFixサーバーを再起動します。
-----------------------------------
<Linux>-------------------------
1) BigFix サーバーのある環境にて、/var/opt/BESServer/besserver.config ファイルを開きます。
2) besserver.config ファイルに「例外リスト」として、カンマ区切りで ILMT サーバーのホスト名、IPアドレスを追加します。
ProxyExceptionList = <proxy_exceptionlist>
例:localhost, 127.0.0.1, ILMTserverHostname, ILMTserverIPアドレス
3) 設定後、ILMT/BigFixサーバーを再起動します。
-----------------------------------
Related Information
Was this topic helpful?
Document Information
Modified date:
26 April 2021
UID
swg22004084