Troubleshooting

If you observe unexpected behaviors or results, the following pages help you resolve issues. To diagnose the problems, enable logging and tracing, and use the Flink web interface. If no installation fault is the cause of your problem, consider how your installation operates.

Troubleshooting installation

Kubernetes deployment
You can check how the installation of the IBM Cloud Pak® for Automation platform rolled out by consulting the operator log files. See Troubleshooting operators.
Single-server deployment
If your IBM Business Automation Insights deployment on a server fails, see Troubleshooting the deployment of IBM Business Automation Insights on a server for causes and corrective actions.

Troubleshooting operation

Common problems
You observe that the expected events don't flow to Kafka or they do flow but do not display in dashboards.
Causes
The causes are most probably with Kafka, with the Elasticsearch pods or security policy, or with the Flink jobs.
Solutions
Learn how to log and trace, and how to use the Flink web interface to diagnose and fix errors.